Go Back   Tahoe Forum - Chevy Tahoe Forum > 2007 + Chevrolet Tahoe / GMC Yukon / Cadillac Escalade Year Models > Technical Discussions

Welcome to the Tahoe Forum - Chevy Tahoe Forum.
Register to remove these ads.


Technical Discussions This forum is for technical discussions related to customizing your Tahoe/Yukon



Reply
 
Thread Tools Display Modes
Old 02-21-2010, 02:16 PM   #1
jazzlara
Tahoeforum Noob
 
Join Date: Jan 2008
Posts: 13
jazzlara is on a distinguished road
Default 2007 Tahoe - Idle Problems?


Register to remove these ads. It's free!
Hello all, need a bit of advice....

-A week or so ago I notice the tahoe not starting as abruptly as it has for 50K. It seemed like it took a second to get the rpm's at normal startup rpm.

-During a couple starts within the next couple of days, I would get the ABS and Traction Control lights displayed.

-Cleaned KN air filter with recharge kit, no change

-I'm the IT consultant for one of the Chevy dealers in my area so I had one of the tech's search for codes. Found 1 related to I guess the brake switch near the pedal.

- Chevy tech cleaned throttle body and cleared codes. SINCE THEN, it seems to not downshift properly, lurches so-to-speak when stopping and feels like the car still wants to go forward. It is usually suprising very gentle when downshifting, not anymore. When the car is in neutral and rolling down my driveway for example, the RPM's will jump to like 2,500 then eventually come back down. AND THE CRAZIEST THING: When I go around turns and leave my foot off the gas and brake when coming out of it, the car increases speed gradually and shifts into 2nd or 3rd...not sure which.

-Chevy tech then replaced throttle body and that brake switch. After he did this, the care seemed back to normal for about 20 miles...local driving, then highway, then noticed it when back on local roads.

No idea at this point. Any ideas?

It idles in park at around 1,000...but if you then put in nutral it may jump to 2500, but not all the time...seems like when our 'rolling'.

The tech did say something about 're-learning' the computer, but he said he did that, plust I've put about 60 miles on the car since at all speeds.

THANKS!

Last edited by jazzlara; 02-21-2010 at 02:23 PM.
jazzlara is offline   Reply With Quote
Old 03-30-2011, 06:11 PM   #2
Makdaddy69
Tahoeforum Noob
 
Join Date: Mar 2011
Location: Alaska
Posts: 1
Makdaddy69 is on a distinguished road
Default

Had same problem with my Tahoe as well... Brought her to the chevy tech and all he did was clean up my throttle position system sensor.all is good no probes since then
Makdaddy69 is offline   Reply With Quote
Old 08-26-2011, 09:27 PM   #3
adamabt
Tahoeforum Noob
 
Join Date: Aug 2011
Posts: 4
adamabt is on a distinguished road
Default

i had this recently happen to my 2003 Tahoe. My mechanic could find nothing when he plugged in a code scanner. I Googled the issue and was directed to a youtube video of a guy using throttle body cleaner to flush out his throttle body to curer a similar issue on his Silverado. For less than 5 bucks and less than an hour i gave it a shot. My idle is now stable, i don't stall and the acceleration is remarkably better....worth a shot!
adamabt is offline   Reply With Quote
Reply

Bookmarks


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



 
Advertisement

Other Sponsors






All times are GMT -4. The time now is 07:38 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
All rights reserved and copyrighted
Fully Driven Auto Network
GM Truck Forum
Ford Raptor Forum
Dodge Ram Forum
Chevy Cobalt Forum
Chevy Camaro Forum
FJ Cruiser Forum
Ford Truck Forum
88-98 GM Truck Forum
73-87 Gm Truck Forum
Ford Expedition Forum
Chevy Equinox Forum
Chevy Cruze Forum
Jeep Liberty Forum
Jeep Forum
Dodge Ram SRT10 Forum
Chrysler 200 Forum
Scion xD Forum
Scion xB Forum
Dodge Challenger Forum
SRT Forum
Nissan Titan Forum
Buick Enclave Forum
Cadillac Forum
Cadillac XTS Forum
TRD Forum
Central US Mopars
Southeast Mopars
Cadillac CTS Forum
Oklahoma Dodge Ram Club
Softball Forum