Go Back   Tahoe Forum - Chevy Tahoe Forum > 2007 + Chevrolet Tahoe / GMC Yukon / Cadillac Escalade Year Models > Technical Discussions

Register to remove these ads.
Technical Discussions This forum is for technical discussions related to customizing your Tahoe/Yukon



Reply
 
Thread Tools Display Modes
Old 09-22-2017, 10:56 AM   #21
NathT
Tahoeforum Apprentice Member
 
NathT's Avatar
 
Join Date: Aug 2012
Location: Jasper, Alabama
Posts: 15
NathT is on a distinguished road
Default TCCM module

Ladybitz, I think since the thread is 3 years old, maybe they did not reply. Did you ever fix your problem? My 2007 started sending a message "SERVICE 4WD" and "SERVICE TRACTION CONTROL" and the truck will not go into 4WD. I changed the dash switch and nothing changed. I had a friend scan it with a super scan tool of his and it gave a code for "lost communication with Transfer Case" I have had no other issues and have been driving it. I really would like to fix it without having to take it to the Stealership.
Nath
NathT is offline   Reply With Quote
Old 09-22-2017, 01:29 PM   #22
Ladybitz
Tahoeforum Newcomer
 
Join Date: Feb 2017
Posts: 3
Ladybitz is on a distinguished road
Default

I took it in about a month ago to pep boys and they ran a diagnostic on the electrical to check for shorts and grounds. They used they're scan tool to try an communicate with all the different modules.They said the transfer case control module was bad. The problem is I tried replacing the module about a year ago and it did not solve my problem. I got it from autozone and they are suppose to be preprogrammed whereas the dealer installs it and then programs it. I actually just ordered a preprogrammed module again last night and will try it again. If that doesn't work I will try the position sensor in the transfer case like someone recommended earlier in this thread. I'll let you know if that solves the problem.
Ladybitz is offline   Reply With Quote
Old 09-30-2017, 08:17 PM   #23
NathT
Tahoeforum Apprentice Member
 
NathT's Avatar
 
Join Date: Aug 2012
Location: Jasper, Alabama
Posts: 15
NathT is on a distinguished road
Default

Ok so I replaced my Brake switch module located on the brake pedal shaft about 2/3 the way up under the dash. I started it up and the "service traction control" "service 4wd" lights went off and the lights on the 4x4 switch lit back up!!! I so happy drove it for about 5 min down the road. Next morning, start it up no lights on 4x4 switch, "service 4wd" back on. Now I have been driving this thing about 12K without 4x4 because i can just push the info button and the warning stops. I am so damn depressed!!!!!\
Nath
NathT is offline   Reply With Quote
Old 10-01-2017, 08:13 PM   #24
Ladybitz
Tahoeforum Newcomer
 
Join Date: Feb 2017
Posts: 3
Ladybitz is on a distinguished road
Default

A new transfer case control module fixed my problem. I installed it a few days ago and wanted to wait to make sure the check engine light didn’t come back on. I’m happy to say that it is finally fixed!!! Finally after a whole year I can use my four wheel drive again! The first one I bought did not mention that you had to plug the 3 harnesses in a certain order...that is probably why it didn’t work the first time I tried it. This time the module came with a sticker that said to plug the four prong harness in last to avoid communication errors. I would definitely try the tccm. I got mine from oreily auto parts. The module is located directly above the E brake release handle. Let me know how it works out for you. Best of luck!
Ladybitz is offline   Reply With Quote
Reply

Bookmarks


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



 
Advertisement

Other Sponsors






All times are GMT -4. The time now is 12:59 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
All rights reserved and copyrighted
Fully Driven Auto Network
GM Truck Forum
Ford Raptor Forum
Dodge Ram Forum
Chevy Cobalt Forum
Chevy Camaro Forum
FJ Cruiser Forum
Ford Truck Forum
88-98 GM Truck Forum
73-87 Gm Truck Forum
Ford Expedition Forum
Chevy Equinox Forum
Chevy Cruze Forum
Jeep Liberty Forum
Jeep Forum
Dodge Ram SRT10 Forum
Chrysler 200 Forum
Scion xD Forum
Scion xB Forum
Dodge Challenger Forum
SRT Forum
Nissan Titan Forum
Buick Enclave Forum
Cadillac Forum
Cadillac XTS Forum
TRD Forum
Central US Mopars
Southeast Mopars
Cadillac CTS Forum
Oklahoma Dodge Ram Club
Softball Forum