Go Back   Tahoe Forum - Chevy Tahoe Forum > Preferred Vendors > 1A Auto

Register to remove these ads.
1A Auto



Reply
 
Thread Tools Display Modes
Old 08-23-2017, 09:48 PM   #1
pete's tahoe
Tahoeforum Newcomer
 
Join Date: Aug 2017
Posts: 1
pete's tahoe is on a distinguished road
Default Breaks-Random hard pedal.

When I come to a slow stop easing into completely stopping. Breaks are good then i get a hard pedal and breaks slip a bit. I have to press hard on pedal then it catches.
I know it's not the break booster-I think I put a new MC. Putting in another incase it's defective. Breaks done twice front and back in 1 year I have had this Tahoe. Would appreciate some insight. Thank you!


Sent from my iPhone using Tapatalk

Last edited by pete's tahoe; 08-24-2017 at 04:12 AM.
pete's tahoe is offline   Reply With Quote
Reply

Bookmarks


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



 
Advertisement

Other Sponsors






All times are GMT -4. The time now is 10:54 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
All rights reserved and copyrighted
Fully Driven Auto Network
GM Truck Forum
Ford Raptor Forum
Dodge Ram Forum
Chevy Cobalt Forum
Chevy Camaro Forum
FJ Cruiser Forum
Ford Truck Forum
88-98 GM Truck Forum
73-87 Gm Truck Forum
Ford Expedition Forum
Chevy Equinox Forum
Chevy Cruze Forum
Jeep Liberty Forum
Jeep Forum
Dodge Ram SRT10 Forum
Chrysler 200 Forum
Scion xD Forum
Scion xB Forum
Dodge Challenger Forum
SRT Forum
Nissan Titan Forum
Buick Enclave Forum
Cadillac Forum
Cadillac XTS Forum
TRD Forum
Central US Mopars
Southeast Mopars
Cadillac CTS Forum
Oklahoma Dodge Ram Club
Softball Forum