Go Back   Tahoe Forum - Chevy Tahoe Forum > 2000 - 2006 Chevrolet Tahoe / GMC Yukon / Cadillac Escalade Year Models > General Tahoe/Yukon/Escalade Discussion Forum

Register to remove these ads.
General Tahoe/Yukon/Escalade Discussion Forum General Tahoe/Yukon/Escalade Discussion Forum



Reply
 
Thread Tools Display Modes
Old 10-14-2012, 07:13 PM   #1
todd273
Tahoeforum Newcomer
 
Join Date: Oct 2012
Posts: 8
todd273 is on a distinguished road
Default Blower motor remains on.

Hey all, Just signed up to try to find out why the blower motor remains on In my Tahoe when it is turned off and the engine is off with the key out? I have to pull the fuse to stop it. 2005 tahoe. Thanks
todd273 is offline   Reply With Quote
Old 10-14-2012, 08:10 PM   #2
Donut Slayer
Full Access Member
 
Join Date: Feb 2009
Location: Pensacola, Florida
Age: 50
Posts: 133
Donut Slayer is on a distinguished road
Default

I believe its gonna be the blower relay. I've read about the same symptoms on the web somewhere. I'll try to find the link.
Donut Slayer is offline   Reply With Quote
Old 10-14-2012, 08:13 PM   #3
Donut Slayer
Full Access Member
 
Join Date: Feb 2009
Location: Pensacola, Florida
Age: 50
Posts: 133
Donut Slayer is on a distinguished road
Default

http://www.truckforums.com/forum/che...-battery-7893/
Donut Slayer is offline   Reply With Quote
Old 10-15-2012, 01:01 PM   #4
todd273
Tahoeforum Newcomer
 
Join Date: Oct 2012
Posts: 8
todd273 is on a distinguished road
Default

Thanks Donut. I just had the condenser replaced and I belive the blower this summer at the dealer and my rear end stil hurts. Do you think this would fall under the one year service garanty? I read the link and to be honest I'm abit stand off'ish when it comes to working on cars. My snowmobiles, duck boat motor, and our I/O no problem. go figure? I just get nervous when it coms to our car's. Because we need them running more than our toys.

Thanks for the advice.

Todd.
todd273 is offline   Reply With Quote
Old 10-15-2012, 05:17 PM   #5
Donut Slayer
Full Access Member
 
Join Date: Feb 2009
Location: Pensacola, Florida
Age: 50
Posts: 133
Donut Slayer is on a distinguished road
Default

I think its a easy fix, but from what I remember, there have been several different designs and you need to look at the old one to match up the new one. Either that or the a/c actuator, I cant remember which. Its hell getting old.
Donut Slayer is offline   Reply With Quote
Old 10-15-2012, 05:20 PM   #6
Donut Slayer
Full Access Member
 
Join Date: Feb 2009
Location: Pensacola, Florida
Age: 50
Posts: 133
Donut Slayer is on a distinguished road
Default

http://www.ehow.com/how_12180732_rep...evy-tahoe.html
Donut Slayer is offline   Reply With Quote
Old 10-15-2012, 05:41 PM   #7
todd273
Tahoeforum Newcomer
 
Join Date: Oct 2012
Posts: 8
todd273 is on a distinguished road
Default

Well that sounds easy enough. Gonna give it a go.

Thanks for the help.

Todd.
todd273 is offline   Reply With Quote
Old 10-16-2012, 08:21 PM   #8
todd273
Tahoeforum Newcomer
 
Join Date: Oct 2012
Posts: 8
todd273 is on a distinguished road
Default

Holy poop!! pulled the blower motor resistor. put the fuse back in with the key out of the engnition, and the motor ran. So I figured n/p I'll just hit the auto part store and I'm done. $350 for a dam resistor!!! the guy told me it's because I have the automatic temp control. On a good note he said it could be a short, and if it is when the part comes in plug it in and if it still runs with the key out he will take the part back and refund the money. So I guess I got that going for me, but it just leads to another issue. If GM had a face I would punch it right now.
todd273 is offline   Reply With Quote
Old 10-17-2012, 10:24 AM   #9
Donut Slayer
Full Access Member
 
Join Date: Feb 2009
Location: Pensacola, Florida
Age: 50
Posts: 133
Donut Slayer is on a distinguished road
Default

Wow, I just looked up a blower motor resistor on rockauto and found it for $95. http://www.rockauto.com/catalog/raframecatalog.php
Donut Slayer is offline   Reply With Quote
Old 10-17-2012, 10:46 AM   #10
todd273
Tahoeforum Newcomer
 
Join Date: Oct 2012
Posts: 8
todd273 is on a distinguished road
Default

I cant find the part on rockauto. Was it an automatic temp contro resistor?
todd273 is offline   Reply With Quote
Reply

Bookmarks


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



 
Advertisement

Other Sponsors






All times are GMT -4. The time now is 01:58 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
All rights reserved and copyrighted
Fully Driven Auto Network
GM Truck Forum
Ford Raptor Forum
Dodge Ram Forum
Chevy Cobalt Forum
Chevy Camaro Forum
FJ Cruiser Forum
Ford Truck Forum
88-98 GM Truck Forum
73-87 Gm Truck Forum
Ford Expedition Forum
Chevy Equinox Forum
Chevy Cruze Forum
Jeep Liberty Forum
Jeep Forum
Dodge Ram SRT10 Forum
Chrysler 200 Forum
Scion xD Forum
Scion xB Forum
Dodge Challenger Forum
SRT Forum
Nissan Titan Forum
Buick Enclave Forum
Cadillac Forum
Cadillac XTS Forum
TRD Forum
Central US Mopars
Southeast Mopars
Cadillac CTS Forum
Oklahoma Dodge Ram Club
Softball Forum