Go Back   Tahoe Forum - Chevy Tahoe Forum > TahoeForum.com > New Member Check-In

Register to remove these ads.
New Member Check-In New to Tahoe Forum? Post here and say hello! Welcome!



Reply
 
Thread Tools Display Modes
Old 03-07-2019, 10:10 AM   #1
Tahoe925
Tahoeforum Newcomer
 
Join Date: Mar 2019
Posts: 3
Tahoe925 is on a distinguished road
Default Rough idle

I have an 04' Tahoe with 179k. I am dealing with a rough idle even after changing the plugs and wires. I added sea foam to my fuel but still running rough. Throttle body has been cleaned, clean Air filter. Someone mentioned to me it could be the Bosch plugs that are in it? Another person mentioned it could be my fuel filter but this is not a flex fuel model in which does not have a fuel filter. Any ideas would be greatly appreciated?
Tahoe925 is offline   Reply With Quote
Reply

Bookmarks


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



 
Advertisement

Other Sponsors






All times are GMT -4. The time now is 01:30 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
All rights reserved and copyrighted
Fully Driven Auto Network
GM Truck Forum
Ford Raptor Forum
Dodge Ram Forum
Chevy Cobalt Forum
Chevy Camaro Forum
FJ Cruiser Forum
Ford Truck Forum
88-98 GM Truck Forum
73-87 Gm Truck Forum
Ford Expedition Forum
Chevy Equinox Forum
Chevy Cruze Forum
Jeep Liberty Forum
Jeep Forum
Dodge Ram SRT10 Forum
Chrysler 200 Forum
Scion xD Forum
Scion xB Forum
Dodge Challenger Forum
SRT Forum
Nissan Titan Forum
Buick Enclave Forum
Cadillac Forum
Cadillac XTS Forum
TRD Forum
Central US Mopars
Southeast Mopars
Cadillac CTS Forum
Oklahoma Dodge Ram Club
Softball Forum