Go Back   Tahoe Forum - Chevy Tahoe Forum > Other Chevy / GMC SUV Models > Suburban / Yukon XL / Escalade ESV

Register to remove these ads.
Suburban / Yukon XL / Escalade ESV Chevrolet Suburban / GMC Yukon XL / Escalade ESV forum



Reply
 
Thread Tools Display Modes
Old 01-06-2014, 09:14 PM   #1
Chris Till
Tahoeforum Newcomer
 
Join Date: Jan 2014
Posts: 1
Chris Till is on a distinguished road
Default Yukon XL Idle Surge

I have an 04 Yukon XL. About a month ago, check engine light came on. Took to my mechanic. Said it was a lean fuel code and to put some additive into gas tank. I did this and it seemed to work. This weekend, it got very cold where I live and engine started to idle rough. RPM's and engine would surge while in park or at a stop light. Took to mechanic today. Computer said MAF sensor was bad. Had it replaced along with fuel filter. Seemed to run normal again while at the shop. Once I got it home, I put it into park and the engine started to surge again while in idle. Although it was not as profound as before, it was still surging. Any suggestions on what to look for next? Thanks for your help and have a blessed week.
Chris Till is offline   Reply With Quote
Old 01-07-2014, 12:14 PM   #2
rockenthebowtie
Full Access Member
 
Join Date: Oct 2013
Location: Any time I want
Posts: 694
rockenthebowtie is on a distinguished road
Default

Try cleaning the throttle body assy.. if that doesnt help it might be the upper intake manifold gaskets
rockenthebowtie is offline   Reply With Quote
Old 01-07-2014, 01:12 PM   #3
laredo1307
Tahoeforum Newcomer
 
laredo1307's Avatar
 
Join Date: Dec 2013
Location: Houston
Posts: 6
laredo1307 is on a distinguished road
Default

Check the intake gasket by spraying some brake cleaner around where the intake gasket is. If the engine stumbles then you probably have a leak.
laredo1307 is offline   Reply With Quote
Old 12-21-2018, 03:06 AM   #4
TeamTahoe
Tahoeforum Newcomer
 
Join Date: Dec 2018
Location: NorCal
Posts: 6
TeamTahoe is on a distinguished road
Default

I have a similar question.
I would like to start a new thread.
How do I go to start a new thread?
TeamTahoe is offline   Reply With Quote
Reply

Bookmarks


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



 
Advertisement

Other Sponsors






All times are GMT -4. The time now is 06:48 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
All rights reserved and copyrighted
Fully Driven Auto Network
GM Truck Forum
Ford Raptor Forum
Dodge Ram Forum
Chevy Cobalt Forum
Chevy Camaro Forum
FJ Cruiser Forum
Ford Truck Forum
88-98 GM Truck Forum
73-87 Gm Truck Forum
Ford Expedition Forum
Chevy Equinox Forum
Chevy Cruze Forum
Jeep Liberty Forum
Jeep Forum
Dodge Ram SRT10 Forum
Chrysler 200 Forum
Scion xD Forum
Scion xB Forum
Dodge Challenger Forum
SRT Forum
Nissan Titan Forum
Buick Enclave Forum
Cadillac Forum
Cadillac XTS Forum
TRD Forum
Central US Mopars
Southeast Mopars
Cadillac CTS Forum
Oklahoma Dodge Ram Club
Softball Forum