Go Back   Tahoe Forum - Chevy Tahoe Forum > Other Chevy / GMC SUV Models > Avalanche / Escalade EXT

Register to remove these ads.
Avalanche / Escalade EXT Chevrolet Avalanche / GMC Escalade EXT forum



Reply
 
Thread Tools Display Modes
Old 02-18-2015, 10:31 PM   #1
dukebear7
Tahoeforum Newcomer
 
Join Date: Jan 2015
Posts: 8
dukebear7 is on a distinguished road
Default No Heat

Having a heating issue with a 1995 Chevy suburban, just had a thermostat put in and last summer a water pump installed. Took notice that the water looked like muddy water could this be the problem.
dukebear7 is offline   Reply With Quote
Old 02-18-2015, 10:35 PM   #2
raiderron
Full Access Member
 
raiderron's Avatar
 
Join Date: Nov 2014
Location: Eugene, Oregon
Age: 64
Posts: 736
raiderron is on a distinguished road
Default

Muddy water could be a source of a clogged heater core. Remove the hoses at the heater core and flush out with water pressure. Replace the thermostat with a 195 degree thermo because it may not be working anymore from the muddy water. When you have the upper hose off at the thermo remove the lower hose and water pressure again thru the radiator. Are you sure you have a properly functioning blend door actuator or any problems with dash controls? Like does the heat only work at defrost but not at the floor....etc.?
raiderron is offline   Reply With Quote
Old 02-18-2015, 10:41 PM   #3
dukebear7
Tahoeforum Newcomer
 
Join Date: Jan 2015
Posts: 8
dukebear7 is on a distinguished road
Default

It throws air all over (dash,floor,defrost)
dukebear7 is offline   Reply With Quote
Old 02-18-2015, 11:34 PM   #4
raiderron
Full Access Member
 
raiderron's Avatar
 
Join Date: Nov 2014
Location: Eugene, Oregon
Age: 64
Posts: 736
raiderron is on a distinguished road
Default

Well if the air comes out at the proper place when the controls are set to that place then I would lean toward what I posted.
raiderron is offline   Reply With Quote
Old 02-19-2015, 08:33 AM   #5
dukebear7
Tahoeforum Newcomer
 
Join Date: Jan 2015
Posts: 8
dukebear7 is on a distinguished road
Default

Thanks for your help will try.
dukebear7 is offline   Reply With Quote
Reply

Bookmarks


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



 
Advertisement

Other Sponsors






All times are GMT -4. The time now is 08:52 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
All rights reserved and copyrighted
Fully Driven Auto Network
GM Truck Forum
Ford Raptor Forum
Dodge Ram Forum
Chevy Cobalt Forum
Chevy Camaro Forum
FJ Cruiser Forum
Ford Truck Forum
88-98 GM Truck Forum
73-87 Gm Truck Forum
Ford Expedition Forum
Chevy Equinox Forum
Chevy Cruze Forum
Jeep Liberty Forum
Jeep Forum
Dodge Ram SRT10 Forum
Chrysler 200 Forum
Scion xD Forum
Scion xB Forum
Dodge Challenger Forum
SRT Forum
Nissan Titan Forum
Buick Enclave Forum
Cadillac Forum
Cadillac XTS Forum
TRD Forum
Central US Mopars
Southeast Mopars
Cadillac CTS Forum
Oklahoma Dodge Ram Club
Softball Forum